require_gem deprecation warnings, redux

So I’ve written about this before – and it turns out that a lot of the “require_gem” deprecation warnings come from tasks in your gem builds that build convenience scripts in /usr/bin (or wherever on your system it places these). So if these convenience scripts (like /usr/bin/mongrel_rails) are left around from installs with previous versions of rubygems – just reinstall the gem (or change all the require_gem statements to just “gem”) yourself.

A grep require_gem /usr/bin/* is pretty convenient to get an idea for the gems you need to reinstall.

However, feedtools 0.2.26 has a bunch of require_gem statements in lib/feed_tools.rb (and littering my crons with the deprecation warnings), so I ended up building and distributing my own replacement with require_gem replaced with gem.